[Fix] Can’t Apply “Windows Aero” Theme After Applying “Windows Basic” Theme in Windows 7

Lots of Windows 7 users have faced this weird issue. We know that we can change Windows themes using Desktop Personalization window. You can apply Windows Aero, Windows Basic, Windows Classic or High Contrast themes using personalization window.

If you switch between Windows Aero and Windows Basic themes several times, one stage comes when you might not be able to switch to Windows Aero theme permanently. No "Please Wait" box is displayed on screen and your display remains in Windows Basic theme.

Changing_Theme_Windows_7.png

Microsoft has confirmed this issue and provided a workaround to fix this problem. A proper hotfix will be released once the root cause of the problem is investigated.

Problem Symptom:

You try to change Windows theme using personalization window and you switch between Windows 7 Basic and Windows 7 Aero themes several times. After several attempts, your display may no longer change and the "Please Wait" dialog box will no longer be displayed while a change is processing. Windows theme will remain in Basic look.

Problem Solution:

There is a workaround to fix this issue. Once this problem occurs, select the Windows Classic or any High Contrast theme and wait for the "Please Wait" dialog box and processing to finish. Now select the Aero theme and Windows will apply Aero glass theme without any problem.





Share this article: Facebook | Twitter | Google+ | Reddit | Tell a friend

Posted in: Troubleshooting, Windows 7


Other similar articles that may interest you


Comments

  • sorry but i tried it and didn't work for me :/

  • i cant apply my windows 7 aero theme even i download other theme and its stays on classic lookT__T

  • VG

    ^^ Make sure Desktop Windows Manager service is running in Services Manager.

  • Don't know if this will help but my wifes ASUS laptop has Windows 7 and would not work for the aero function. Would not get the "please wait". The proposed workaround to select Classic or High Contrast got "please wait" but would still not work to select aero. Would get the "please wait" but would default to Basic. Just as a side fix to other problems slowing her computer, downloaded from CNET and ran C-Cleaner. Bottom line after performing the cleaning the Aero mode now works. May have deleted and old file of some sort causing the Aero not to operate. C-Cleaner seems to clear alot of old temp files and have no problem with the its installation or operation.

  • VG

    ^^ Thanks for your input. I'm sure it'll help others. :)

  • Make sure your start up selection is set to normal. To do so just type "msconfig" without quotes in start and press enter. You will get a prompt asking you and press yes. If you arrive in system configuration, just click general tab, and i start up selection make sure normal start up is selected then press OK, they will ask you to restart you computer and do so. I hope this will solve your problem.

  • thanks..it fix my problemm..!!

  • Hi, IT WORKED FOR ME. THANK YOU SO MUCH MILLIONS. THANKS. UFFF

Leave a Comment

(required)